BGP引入实验,华为ensp模拟器

news/2024/7/10 2:02:23 标签: bgp, 路由引入, rip, ospf, 路由策略, 前缀列表

一个小作业题,中间三台路由器bgp 100 分支用ripospf,最后如有引入时通过前缀列表精确匹配和路由策略调用,都是一些基本配置,考研学生们的基本功扎不扎实,从最最基础的接口配ip,到igp的路由配置,bgp路由配置,前缀列表路由策略配置,路由引入

配置如下

R1
 sysname R1
#
interface GigabitEthernet0/0/0
 ip address 10.0.12.1 255.255.255.0 
#
interface LoopBack0
 ip address 10.0.1.1 255.255.255.255 
#
rip 1
 version 2
 network 10.0.0.0

R2
 sysname R2
#
interface GigabitEthernet0/0/0
 ip address 10.0.23.2 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 10.0.12.2 255.255.255.0 
#
interface LoopBack0
 ip address 10.0.2.2 255.255.255.255 
#
bgp 100
 router-id 10.0.2.2
 peer 10.0.23.3 as-number 100 
 peer 10.0.34.4 as-number 100 
 #
 ipv4-family unicast
  undo synchronization
  network 10.0.2.2 255.255.255.255 
  import-route rip 1 route-policy l
  peer 10.0.23.3 enable
  peer 10.0.23.3 next-hop-local 
  peer 10.0.34.4 enable
  peer 10.0.34.4 next-hop-local 
#
rip 1
 default-route originate
 version 2
 network 10.0.0.0
#
route-policy 1 permit node 10 
 if-match ip-prefix 1 
#
ip ip-prefix 1 index 10 permit 10.0.1.1 32
#
ip route-static 10.0.34.0 255.255.255.0 10.0.23.3


R3
 sysname R3
#
interface GigabitEthernet0/0/0
 ip address 10.0.23.3 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 10.0.34.3 255.255.255.0 
#
interface LoopBack0
 ip address 10.0.3.3 255.255.255.255 
#
bgp 100
 router-id 10.0.3.3
 peer 10.0.23.2 as-number 100 
 peer 10.0.34.4 as-number 100 
 #
 ipv4-family unicast
  undo synchronization
  network 10.0.3.3 255.255.255.255 
  peer 10.0.23.2 enable
  peer 10.0.34.4 enable


R4
 sysname R4
#
interface GigabitEthernet0/0/0
 ip address 10.0.34.4 255.255.255.0 
#
interface GigabitEthernet0/0/1
 ip address 10.0.45.4 255.255.255.0 
#
interface LoopBack0
 ip address 10.0.4.4 255.255.255.255 
#
bgp 100
 router-id 10.0.4.4
 peer 10.0.23.2 as-number 100 
 peer 10.0.34.3 as-number 100 
 #
 ipv4-family unicast
  undo synchronization
  network 10.0.4.4 255.255.255.255 
  import-route ospf 1 route-policy 1
  peer 10.0.23.2 enable
  peer 10.0.23.2 next-hop-local 
  peer 10.0.34.3 enable
  peer 10.0.34.3 next-hop-local 
#
ospf 1 router-id 10.0.4.4 
 default-route-advertise always
 area 0.0.0.0 
  network 10.0.45.0 0.0.0.255 
#
route-policy 1 permit node 10 
 if-match ip-prefix 1 
#
ip ip-prefix 1 index 10 permit 10.0.5.5 32
#
ip route-static 10.0.23.0 255.255.255.0 10.0.34.3


R5
 sysname R5
#
interface GigabitEthernet0/0/0
 ip address 10.0.45.5 255.255.255.0 
#
interface LoopBack0
 ip address 10.0.5.5 255.255.255.255 
#
ospf 1 router-id 10.0.5.5 
 area 0.0.0.0 
  network 10.0.5.5 0.0.0.0 
  network 10.0.45.0 0.0.0.255 




http://www.niftyadmin.cn/n/5190782.html

相关文章

懒羊羊闲话4 - 献给那些苦于学习无法入门的同学

1、学习为啥那么难 学过物理学的同学都知道,有个很重要的概念-熵、熵指的是物质的混乱程度。宇宙存在一个定律:宇宙熵增定律。就是说物质是从有规则变为混乱。 打个比方,往水里投入一颗钠,一开始钠会剧烈的燃烧,然后在…

【洛谷 P2678】[NOIP2015 提高组] 跳石头 题解(二分答案+递归)

[NOIP2015 提高组] 跳石头 题目背景 一年一度的“跳石头”比赛又要开始了! 题目描述 这项比赛将在一条笔直的河道中进行,河道中分布着一些巨大岩石。组委会已经选择好了两块岩石作为比赛起点和终点。在起点和终点之间,有 N N N 块岩石(不…

【笔记 Pytorch】稀疏矩阵、scipy.sparse模块的使用

安装:pip install scipy 描述:就是专门为了解决稀疏矩阵而生。导入模块:from scipy import sparse 优缺点总结 七种矩阵类型描述coo_matrix ★【名称】coordinate format 【优点】    ① 不同稀疏格式间转换效率高(特别是CSR和CSC)  …

一键解决WARNING: The repository located at mirrors .aliyun.com is not a trusted or secure host and is be

这个错误提示是由于pip在下载软件包时,发现了一个不受信任的镜像源,因此默认情况下会忽略它。 文章目录 问题描述解决思路解决方法 问题描述 WARNING: The repository located at mirrors .aliyun.com is not a trusted or secure host and is being ig…

Auto.js 清除指定应用缓存

本文所有教程及源码、软件仅为技术研究。不涉及计算机信息系统功能的删除、修改、增加、干扰,更不会影响计算机信息系统的正常运行。不得将代码用于非法用途,如侵立删!Auto.js 清除指定应用缓存 环境 win10Pixel4Android13var packageName = ""; // 包名 var resu…

构建自定义ChatGPT,微软推出Copilot Studio

11月16日,微软在美国西雅图举办“Microsoft Ignite 2023”全球开发者大会。本次人工智能成为重要主题,微软几乎把所有产品都集成了生成式AI功能并发布了一系列全新产品。 其中,微软重磅推出了Copilot Studio(预览版)&…

spring cloud openfeign 使用注意点

近期在做项目时给自己挖了一个坑,问题重现如下 使用的组件版本如下 spring boot 2.7.15,对应的 spring cloud 版本为 2021.0.5,其中 spring cloud 适配的 openfeign 版本是 3.1.5。 项目中使用的 feign 接口如下 public interface QueryApi…

宝塔https403默认串站问题解决

1 前言 宝塔面板 https 串站 在这里引用宝塔官方说法:在未指定 SSL 默认站点时,未开启 SSL 的站点使用 HTTPS 会直接访问到已开启 SSL 的站点 相信使用宝塔面板的盆友,应该都遇到过宝塔这个 https 串站问题。很多盆友遇到了,但忽略了它,觉得没啥影响的,就置之不理了... …